AWS has communicated that they have fully resolved the issues and we are happy to announce that we are fully up and running again. Following from this incident, we will be doing discovery work to identify the gaps in our mitigation plan to better manage future incidents of a similar nature.
Posted Oct 20, 2025 - 23:22 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 11:31 UTC
Update
Most large issues have been resolved by AWS. AWS still mentions that there can be some delays and degraded performance, but are working towards full mitigation.
Posted Oct 20, 2025 - 11:27 UTC
Monitoring
An issue in the US-EAST-1 Region is impacting different services/applications that make use of it. Gorilla US customers can incur degraded performance. We have seen it impact a non-US customer where calculations could fail or have degraded performance. It is currently looking stable for non-US customers. AWS is aware and are actively resolving the issues and are seeing significant signs of recovery. We're reaching out through other channels as well.
Statuspage was also affected and is cause of the late communication.